PHP: Hypertext Preprocessor, popularly known as PHP, is a popular coding language, which can be used to set up dynamic websites with interactive components like message boards, online teaching websites or social networking websites. In stark contrast with static HTML websites, a PHP website can serve unique web content to each user under the exact same URL. Because PHP-based web apps can be managed through one single Control Panel, which you can sign onto from any online browser, you will not need to possess any web design experience or prior experience to run a PHP-powered site. The fact that 100s of millions of sites all over the world are based on PHP is an indication of the language’s popularity and ease of use. You only have to ensure that the server where you host your site supports the very same PHP version as the one that you used whilst building the site.

PHP 4 and PHP 5 Support in Shared Web Hosting

With our shared web hosting services, you will be able to select the PHP version that will be active for your hosting account, as different versions are installed on our servers. With only one mouse click, you will be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and every time a new version is introduced in the future, we’ll add it to the Hepsia hosting Control Panel without removing the earlier ones. Thus, you will be able to host all the sites that you’ve built through the years. In stark contrast with many other web hosting suppliers, we won’t compel you to update such websites, because a script may be outdated, but this does not automatically mean that it’s vulnerable since you may have implemented modifications to its code to prevent safety holes. For your convenience’s sake, you will even be able to pick a different PHP version for each website that you host in your shared hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Even if your sites were created with an older version of PHP, you’ll be able to host them in a semi-dedicated server account from us, since we support multiple versions running simultaneously on our semi-dedicated servers and each of them can be enabled for your account with just a click through our in-house built Hepsia Control Panel. Apart from the most recent PHP 5.5 and PHP 5.4, we also offer 5.3, 5.2 and the older PHP 4, which has already been abandoned by the vast majority of hosting providers, but we strongly consider that you should not be forced to modify a site that took several years to develop, as older scripting language syntax doesn’t always mean security vulnerabilities. On the contrary, a rightly maintained website using PHP 4 can be more secure than a wrongly maintained one using PHP 5. For your convenience’s sake, we’ll also provide you with the opportunity to specify a different version for each individual site within the account.